N!tmod

Welcome to N!tmod Bug Tracker.
IDSummaryOperating SystemCategoryOpened by  ascSeverityStatusLast Edited
 19  panza bug All / UndefinedClientKovacs DanielLowClosed2010-11-11 Task Description ! Please specify the bug type in the summary ! * N!tmod version : 2.0 I choise at warmup panza. its in my hand when the match start first time i spawn with thomson. Need select again the panza in the limbo.
 18  No autoswitch when your weapon empty All / UndefinedServerKovacs DanielMediumClosed2010-10-25 Task Description ! Please specify the bug type in the summary ! * N!tmod version : 2.0 No autoswitch when your weapon empty. You shot with your Thomson/MP40 ammo out and the weapon dosent swith auto to the secondary weapon. (And yes in the ESC->Options->Game menu is setted to "yes" the autoswitch option)
 20  Multi announcers All / UndefinedClientKovacs DanielLowClosed2010-10-25 Task Description ! Please specify the bug type in the summary ! * N!tmod version : 2.0 If you kill 6 players you will all the mk3-5 files instead of the only one mk5 wav.
 10  ammo pack image bug-2 All / UndefinedServerKovacs DanielLowClosed2010-10-11 Task Description ! Please specify the bug type in the summary ! * N!tmod version : 2.0 sry i modifi my preivus report with the ammo pack bug: well, it work fine unitil level 4, but when you reach the level 5 skill as fieldops you see again the standard ammopack ( at the beginning you see models\multiplayer\supplies\ammobox.tga with higher skill you see models\multiplayer\supplies\ammobox_2.tga but with level 5 - again models\multiplayer\supplies\ammobox.tga
 3  ammo pack image bug WindowsServerKovacs DanielLowClosed2010-10-10 Task Description ! Please specify the bug type in the summary ! * N!tmod version : 2.0 * Description: at "Signals Level 1: Improved Resources" you drop ammopack which contain an extra clip. Normally the iamge changeing also from "models\multiplayer\supplies\ammobox.tga" to "models\multiplayer\supplies\ammobox_2.tga" But here the image dosent changing.
 17  !banlist missing All / UndefinedClientKovacs DanielMediumClosed2010-10-25 Task Description ! Please specify the bug type in the summary ! * N!tmod version : 2.0 as admin i should have all (72) cmds. I banned a guy but wanted unbanning. But i dont have the !banlist to search on the list that what is the name/number of the banned guy
 32  missing trigger All / UndefinedServerMarekLowClosed2011-11-07 Task Description * N!tmod version : 2.1-RC1 * Build Date (!about cmd) : * Map : frostbite * Omni-Bot enabled ? : yes * If yes, bot count : 20 * Gametype : * Any custom mapscripts ? If yes, provide link : * Any LUA modules ? If yes, provide link : * Happens in Warmup/Playing/Intermission ? : playing * Explain the bug : When I am creating script for Omni-bot 0.81 sometimes I need use trigger "....dropped". If I have running server with ETMain with Omni-bot then this trigger is displayed in console - e.g. trigger for map Frostbite in ETMain: "the Supply Documents dropped.". But N!tmod and NQ (1.2.9.b6) mod this trigger hasn't. I asked Omni-bot developers why this trigger is not displayed in NQ or N!tmod and answers were (by crapshoot): " most likely the mods are missing code for that trigger. " and " the mod sends trigger info to the bot through the interface. " My question: Is it possible make modification in N!tmod ? * Additional informations :
 26  tripmine kill dosent count in the XP All / UndefinedClientMyLowClosed2010-12-23 Task Description * N!tmod version : Nitmod public testserver, today I used tripmines many times, but the kills dosent showed on my xp and the skills also not groved. F.e. If you kill somebody with mp40 your get +3 xp point and your light weapon skill also growing with 3 points. So what have to fixing? If you kill somebody with tripmine your xp growing and also your engi skill also growing.
 37  Goomba (and probably some other MOD's) are not announce ...All / UndefinedClientN!trox*LowClosed2011-12-13 Task Description * N!tmod version : 2.2b2 * Explain the bug : No popup message for MOD_GOOMBA kills This is probably the case for some other MOD's, didn't test yet. Added this as a reminder, and at least nobody will report it again.
 13  server_motd0 "" breaks MOTD LinuxServerNoneVery LowClosed2010-10-21 Task Description ! Please specify the bug type in the summary ! * N!tmod version : 2.0 * Map : all * Omni-Bot running : 0.8 * Gametype : 2 * Custom mapscripts : battery.script, oasis.script, radar.script, railgun.script, fueldump.script, goldrush.script * LUA modules : rules.lua, dynamite_counter.lua * Warmup/Playing/Intermission : Loading * Have you noticed anything else that could help us, for exemple, is there anything special supposed to happen in the map when the crash happens : nope If you put this: set server_motd0 "" In the server.cfg or nitmod.cfg then the whole motd is not shown (like it's empty)
 15  g_msgpos "1" doesn't work LinuxServerNoneLowClosed2010-10-21 Task Description ! Please specify the bug type in the summary ! * N!tmod version : 2.0 * Map : all * Omni-Bot running : 0.8 * Gametype : 2 * Custom mapscripts : battery.script, oasis.script, radar.script, railgun.script, fueldump.script, goldrush.script * LUA modules : rules.lua, dynamite_counter.lua * Warmup/Playing/Intermission : Loading * Have you noticed anything else that could help us, for exemple, is there anything special supposed to happen in the map when the crash happens : nope set g_msgpos "1" Doesn't work, I've tried pretty much everything. When I change g_msgpos to 2 then everything works fine, the messages appear at the top of the screen, with 1 nothing happens.
 14  /team <parameter> - No control + No secondary weapon WindowsClientNoneLowClosed2010-11-05 Task Description * N!tmod version : 2.0 * Map : all * Omni-Bot running : 0.8 * Gametype : 2 * Custom mapscripts : battery.script, oasis.script, radar.script, railgun.script, fueldump.script, goldrush.script * LUA modules : rules.lua, dynamite_counter.lua * Warmup/Playing/Intermission : Loading * Have you noticed anything else that could help us, for exemple, is there anything special supposed to happen in the map when the crash happens : nope There doesn't seem to be a control on the /team command I join my server the teams are like this: allies 8 players axis 7 players I type /team haha it puts me in axis team (that's ok) But you spawn as soldier without a secondary weapon. I don't know what happens when the teams are balanced.
 33  baserace_desert crash on nitmod 2.1 RC1 LinuxServerPiotrMediumClosed2011-11-07 Task Description * N!tmod version : 2.1 RC1 * Build Date (!about cmd) : Jan 27 2011 * Map : baserace_desert * Omni-Bot enabled ? : enabled 0.81 * If yes, bot count : 12 * Gametype : map voting * Any custom mapscripts ? If yes, provide link : default baserace_desert mapscript * Any LUA modules ? If yes, provide link : none * Happens in Warmup/Playing/Intermission ? : Happens in the middle of the game. * Explain the bug : Server crashes in the middle of baserace_desert map. Everything was ok for about a month and suddenly server started to crash during baserace_desert. * Additional informations : Crashlog 2333:20 -88- 2333:20 Version: nitmod 2.1-rc1 Jan 27 2011 Enemy Territory, ET 2.60 2333:20 Map: baserace_desert 2333:20 Signal: Segmentation fault (11) 2333:20 Siginfo: 0xbfa9db4c 2333:20 Code: 1 2333:20 Faulting Memory Ref/Instruction: 0xaf8 2333:20 DSO Information: 2333:20 0xb7850000 (unknown) 2333:20 0xb7843000 /lib/libdl.so.2 2333:20 0xb781d000 /lib/libm.so.6 2333:20 0xb76d8000 /lib/libc.so.6 2333:20 0xb784f000 /lib/ld-linux.so.2 2333:20 0xb2626000 /lib/libnss_compat.so.2 2333:20 0xb260f000 /lib/libnsl.so.1 2333:20 0xb2604000 /lib/libnss_nis.so.2 2333:20 0xb25f8000 /lib/libnss_files.so.2 2333:20 0xb25f1000 /lib/libnss_dns.so.2 2333:20 0xb25dc000 /lib/libresolv.so.2 2333:20 0xaefe6000 /lib/librt.so.1 2333:20 0xaefcd000 /lib/libpthread.so.0 2333:20 0xaf212000 /home/servers/s14051/nitmod/qagame.mp.i386.so 2333:20 0xaf11a000 /usr/lib/gcc/i686-pc-linux-gnu/4.4.3/libstdc++.so.6 2333:20 0xaf0fe000 /usr/lib/gcc/i686-pc-linux-gnu/4.4.3/libgcc_s.so.1 2333:20 0xaebec000 ./omni-bot//omnibot_et.so 2333:20 Stack frames: 0 entries 2333:20 Backtrace: 2333:20 -88- 2333:20 Attempting to clean up.
7Misc Deathmatch glitchesAll / UndefinedClientRaviMediumNew2015-01-04 Task Description * N!tmod version : 2.0 * Map : All * Omni-Bot running : Yes * Gametype : 8 * Custom mapscripts : Deathmatch scripts * LUA modules : N/A * Warmup/Playing/Intermission : Playing I have posted a bunch of bugs together because I didn't see the need for a new topic. Here they are: 1.After killing someone, player health is increased by 20, or set to 112 if it would otherwise exceed this value. However, the max health for medics is 125. Everytime they kill someone with full health, they lose 10 health. 2.There is also a glitch with weapon drops. If a player is killed after picking any primary weapon and an mp40 is in their inventory, they will drop an mp40. 3.Player health does not increase after killing someone if they have killed that person with poison.
 6  Deathmatch glitches: Player team issues All / UndefinedClientRaviHighClosed2010-11-11 Task Description * N!tmod version : 2.0 * Map : All * Omni-Bot running : Yes * Gametype : 8 * Custom mapscripts : Deathmatch scripts * LUA modules : N/A * Warmup/Playing/Intermission : Playing During any deathmatch mode, there are several bugs related to team. While the scoreboard correctly reports players kills, the drop down statistics bar for the player does not. It is also impossible to goomba players "on your team" while certain goomba flags are set.
 1  Sample Bug Report - Crash on Baserace All / UndefinedServerSample UserCriticalClosed2014-11-04 Task Description ************************************************ * * * This is a sample Bug report. * * We have created it for you to see * * how to correctly report bugs in our tracker * * * * NOTE: * * This bug exits for real, and has been * * fixed for N!tmod next version (2.1) * * * ************************************************ * N!tmod version : 2.0 * Map : baserace * Omni-Bot running : Yes * Gametype : 2 * Custom mapscripts : none * LUA modules : none * Warmup/Playing/Intermission : Warmup & Intermission * Have you noticed anything else that could help us, for exemple, is there anything special supposed to happen in the map when the crash happens : Happens when a player walks on a landmine that has been planted by the map.
 51  no Nguide  WindowsServerSaschaLowClosed2013-11-09 Task Description PLEASE FILL THIS FORM PROPERLY TO MAKE SURE WE HAVE ENOUGH INFORMATIONS TO REPRODUCE THE BUG AND TRY TO FIX IT ! THE FOLLOWING FORM HAS BEEN MODIFIED ON MARCH 12th 2011. * N!tmod version : 2.2final * Build Date (!about cmd) : * Map : all Maps * Omni-Bot enabled ? : Yes * If yes, bot count : 8 * Gametype : 2 * Any custom mapscripts ? If yes, provide link : no * Any LUA modules ? If yes, provide link : * Happens in Warmup/Playing/Intermission ? : by conecting * Explain the bug : Some users without a Nguid cant get an guid and the conection were rejected. But i have in the nitmod cfg set g_GUIDChecks "0" * Additional informations : server ip 46.228.199.143:27960 2.55
 46  XP lost sometimes LinuxServerSimonHighClosed2013-11-09 Task Description PLEASE FILL THIS FORM PROPERLY TO MAKE SURE WE HAVE ENOUGH INFORMATIONS TO REPRODUCE THE BUG AND TRY TO FIX IT ! THE FOLLOWING FORM HAS BEEN MODIFIED ON MARCH 12th 2011. * N!tmod version : 2.2 final * Build Date (!about cmd) : may 31 2012 * Map : more * Omni-Bot enabled ? : yes * If yes, bot count : 1-10 * Gametype : 6 * Any custom mapscripts ? If yes, provide link : no * Any LUA modules ? If yes, provide link : no * Happens in Warmup/Playing/Intermission ? : Login * Explain the bug : Sometimes when a client who has XPs, seems has 0 XP. After relog the XPs will be back. * Additional informations : Probably SQLite bug?
 48  wm_sayplayerclass' "IamFieldOps" tesxt sometimes confus ...All / UndefinedClientSimonLowClosed2012-07-16 Task Description PLEASE FILL THIS FORM PROPERLY TO MAKE SURE WE HAVE ENOUGH INFORMATIONS TO REPRODUCE THE BUG AND TRY TO FIX IT ! THE FOLLOWING FORM HAS BEEN MODIFIED ON MARCH 12th 2011. * N!tmod version : 2.2 final * Build Date (!about cmd) : may 12 2012 * Map : any * Omni-Bot enabled ? : yes * If yes, bot count : 1-10 * Gametype : 6 * Any custom mapscripts ? If yes, provide link : no * Any LUA modules ? If yes, provide link : no * Happens in Warmup/Playing/Intermission ? : Playing * Explain the bug : Someitmes the wm_sayplayerclass IamFieldOps' text write other cast. (The sound is correct.) * Additional informations : Usually it reproducateable when the player go to Spectators and get back to team of course as in Field Ops.
 50  kkrcon is timeouting All / UndefinedClientSimonLowClosed2013-11-09 Task Description PLEASE FILL THIS FORM PROPERLY TO MAKE SURE WE HAVE ENOUGH INFORMATIONS TO REPRODUCE THE BUG AND TRY TO FIX IT ! THE FOLLOWING FORM HAS BEEN MODIFIED ON MARCH 12th 2011. * N!tmod version : 2.2 final * Build Date (!about cmd) : may 31 2012 * Map : more * Omni-Bot enabled ? : yes * If yes, bot count : 1-10 * Gametype : 6 * Any custom mapscripts ? If yes, provide link : no * Any LUA modules ? If yes, provide link : no * Happens in Warmup/Playing/Intermission ? : Anytimes * Explain the bug : kkrcon (http://sourceforge.net/projects/kkrcon/) can't connect via rcon to ET running N!tmod 2.2. The earlier version could do that, * Additional informations : I made a workarund indepenting by kkrcon in Perl: $hostname = 'ip.ip.ip.ip'; #ip address $port = '27960'; $protocol = "udp"; $et = IO::Socket::INET->new( PeerAddr => $hostname, PeerPort => $port, Proto => $protocol, #Type => SOCK_STREAM ) or die "Could not open port.\n"; print $et "\377\377\377\377rcon password exec command"; undef $data; my $status = ""; local $SIG{ALRM} = sub { die "alarm\n"; }; # NB \n required alarm(1); eval { while ( recv( $et, $status, 1024, 0 ) ) { my $size = length($status); $status =~ s/^\377\377\377\377//; $status =~ s/print\n//; $data .= $status; } }; alarm(0); That is never lost the time and works, usable. Actually I suppose, N!trox, please find kkrcon why doesn't get answer from 2.2 final...
 52  In objectivecycle mode sometimes a map ruts (sticks) -  ...All / UndefinedServerSimonMediumClosed2013-11-09 Task Description PLEASE FILL THIS FORM PROPERLY TO MAKE SURE WE HAVE ENOUGH INFORMATIONS TO REPRODUCE THE BUG AND TRY TO FIX IT ! THE FOLLOWING FORM HAS BEEN MODIFIED ON MARCH 12th 2011. * N!tmod version : 2.2 final * Build Date (!about cmd) : may 31 2012 * Map : more * Omni-Bot enabled ? : yes * If yes, bot count : 1-10 * Gametype : 6 * Any custom mapscripts ? If yes, provide link : no * Any LUA modules ? If yes, provide link : no * Happens in Warmup/Playing/Intermission ? : end of a map * Explain the bug : Gametype: 6! In objectivecycle mode sometimes a map ruts (sticks) - !nextmap doesn't help. BUT when someone votes at least for one map the server starts that one correctly. When no one vote for any map the objectivecycle.cfg does not work. * Additional informations : Workaround to fix it: /rcon exec objectivecycle.cfg.
 45  Clients lost connections after maps (SQLite bug: Com_Pu ...LinuxServerSimonCriticalClosed2012-09-13 Task Description PLEASE FILL THIS FORM PROPERLY TO MAKE SURE WE HAVE ENOUGH INFORMATIONS TO REPRODUCE THE BUG AND TRY TO FIX IT ! THE FOLLOWING FORM HAS BEEN MODIFIED ON MARCH 12th 2011. * N!tmod version : 2.2 final * Build Date (!about cmd) : may 31 2012 * Map : more * Omni-Bot enabled ? : yes * If yes, bot count : 1-10 * Gametype : 6 * Any custom mapscripts ? If yes, provide link : no * Any LUA modules ? If yes, provide link : no * Happens in Warmup/Playing/Intermission ? : Under intermission most of players lost connection to server. * Explain the bug : ++++ [CloseSQLite] Success ^2 ^2-- Script System Info -- ^2Current Memory Usage 1.66377 MB ^2Soft Memory Usage 1.6 MB ^2Hard Memory Limit 2 MB ^2System Memory Usage 1.49833 MB ^2Full Collects 1 ^2Inc Collects 2 ^2GC Warnings 0 ^2Threads: 6, 0 Running, 0 Blocked, 6 Sleeping Sys_LoadDll(/home/et255/server/nitmod/qagame.mp.i386.so)... ok Sys_LoadDll(qagame) found **vmMain** at 0xd2e7a9e0 Sys_LoadDll(qagame) succeeded! WARNING: Com_PushEvent overflow Usually the Linux clients never lost connections or I'm just lucky. Now I try to give more memory to the game. * Additional informations :
 59  Unavailble maplist on menu for referee status All / UndefinedClientSt├ęphaneMediumClosed2013-11-09 Task Description PLEASE FILL THIS FORM PROPERLY TO MAKE SURE WE HAVE ENOUGH INFORMATIONS TO REPRODUCE THE BUG AND TRY TO FIX IT ! THE FOLLOWING FORM HAS BEEN MODIFIED ON MARCH 12th 2011. * N!tmod version : 2.2 final * Build Date (!about cmd) : * Map : all * Omni-Bot enabled ? : yes(0.8.2) * If yes, bot count : 2 * Gametype : map voting * Any custom mapscripts ? If yes, provide link : yes (supply mapscript for spawn ammo/health cabinets) * Any LUA modules ? If yes, provide link : yes (dynamite counter, rules, cvar) * Happens in Warmup/Playing/Intermission ? : playing * Explain the bug : on our map voting, the referee map choice doesn't exist anymore. You can vote for a map as a normal player, but a referee hasn't a maplist on the menu to choose the map. * Additional informations : this bug appears only since we changed for the map voting system
 31  GARAND/K43 AMMUNATION BUG All / UndefinedServerSt├ęphaneLowClosed2011-03-13 Task Description BUG : ON A SERVER WHERE YOU CAN PICK UP EVERY WEAPONS, THE ENGINEER'S GARAND/K43 IS ALWAYS EMPTY WHEN YOU PICK IT UP ON THE GROUND. * N!tmod version : 2.1 RC1 * Map : ALL * Omni-Bot running : NO * Gametype : OBJECTIVE * Custom mapscripts : YES (WARBELL, SUPPLYDEPOT) * LUA modules : RULES, DYNAMITE_COUNTER * Warmup/Playing/Intermission : 25/12/23 * Have you noticed anything else that could help us, for exemple, is there anything special supposed to happen in the map when the bug occurs : NO
 65  It is only the crosshairs displayed WindowsClientUweLowClosed2013-11-09 Task Description PLEASE FILL THIS FORM PROPERLY TO MAKE SURE WE HAVE ENOUGH INFORMATIONS TO REPRODUCE THE BUG AND TRY TO FIX IT ! THE FOLLOWING FORM HAS BEEN MODIFIED ON MARCH 12th 2011. * N!tmod version : 2.2 Final * Build Date (!about cmd) : May 30 2012 * Map : all Maps * Omni-Bot enabled ? : yes * If yes, bot count : 6 * Gametype :2 * Any custom mapscripts ? If yes, provide link : no * Any LUA modules ? If yes, provide link : lua 5.1 / 51 .dll * Happens in Warmup/Playing/Intermission ? : all * Explain the bug : Hi, I have installed on my computer Nitmod 2.2. The mod is set up as a server. There is only one small problem, no matter what class I choose games, it appears we only the crosshairs. Can someone help me? * Additional informations : none
 22  Leaning Bomb Bug LinuxClientVadimMediumClosed2010-11-08 Task Description ! Please specify the bug type in the summary ! * N!tmod version : 2.0 final * Map : all * Omni-Bot running : Yes. 0.8 * Gametype : Map Voting * Custom mapscripts : - * LUA modules : - * Warmup/Playing/Intermission : Playing Description: When shooting while leaning is enabled. g_weapons 256. You can lean while timing bomb. If you want to throw it while leaning, it stucks. You basically can't switch weapons and the bomb stays in the hand. If you get killed, it explodes right after it.
 5  Incognito Bug. (!Listplayers) LinuxClientVadimHighClosed2012-01-24 Task Description N!tmod Verison: 2.0 Final Bug description: Incognito Bug. - An Admins level can be seen by !Listplayers even he got the incognito flag. [level] level = 999 name = ^0Server God flags = incognito all greeting = greeting_sound = (/!readconfig was done after it was added in shrubbot.cfg - no affect, the incognito flag gets removed sometimes, so only the all flag reminds) Screen: [URL=http://img401.imageshack.us/i/incognitoh.jpg/][IMG]http://img401.imageshack.us/img401/3096/incognitoh.th.jpg[/IMG][/URL] As you can see, all flag is included, incognito flag isn't. Even though it got added in the shrubbot.cfg and a !readconfig was made.
 24  g_inactivityOptions + Inactivity (shrubbot flag) LinuxServerVadimVery LowClosed2010-12-23 Task Description ! Please specify the bug type in the summary ! * N!tmod version : 2.0 Final * Map : - * Omni-Bot running : - * Gametype : - * Custom mapscripts : - * LUA modules : - * Warmup/Playing/Intermission : Playing * Have you noticed anything else that could help us, for exemple, is there anything special supposed to happen in the map when the bug occurs : Having g_inactivityOptions enabled.. wearing the Inactivity Shrubbot flag, which means the player can't be put to spec/kicked by g_inactivity, g_spectatorInactivity and g_inactivityOptions. But i still see the notification (30 Seconds until moving to Spectators for Inactivity)
 8  Rifle grenade bug All / UndefinedServeryourauntyHighClosed2013-11-09 Task Description ! Please specify the bug type in the summary ! * N!tmod version : 2.0 * Map : every * Omni-Bot running :0.8 * Gametype : map voting * Custom mapscripts : none * LUA modules : none * Warmup/Playing/Intermission : 10 seconds * Have you noticed anything else that could help us, for exemple, is there anything special supposed to happen in the map when the crash happens : reported this bug to you last time after 1.6 developed, you must of overlooked it or just forgot:) when you try to load a rifle grenade ( happens all the time on allies) it just keeps reloading itself..sometimes 2 or 3 times before you can fire...very annoying when your trying to pop a rifle nade off at the enemy, this happens to all my cleints with 1.6 and 2.0 so must be a bug with nitmod cheers
Showing tasks 51 - 79 of 79 Page 2 of 2 - 1 - 2

Available keyboard shortcuts

Tasklist

Task Details

Task Editing